Summer 2023 Virtual Programming Contest

August 12, 2023 9:15 AM - August 12, 2023 3:30 PM PDT
430
Total Participants
159
Total Teams
9.4%
Year-over-year Growth
Novice/Advanced
Divisions
TeamsCode Summer 2023 Online Programming Contest will take place on Saturday, August 12th, from 9:15 AM to 3:30 PM (Pacific Time) through a Youtube livestream! Computer science students are welcomed to join this competitive programming experience! Teams of up to 4 students will spend 3 hours solving interesting algorithmic problems. There will be two divisions: Novice and Advanced. Prizes will be given out, including placement awards, raffle prizes, and more! Only pre-college participants are eligible for prizes.

Contest Winners

Advanced Division
1st
noobab 4 seirrac 3 !iiawak ~ayn づ( ◕‿◕ づ) 3x rwar kcuhC 🐛 🐛 🐛 🐔 worcestershire sauce
Eric Hsu, Julian Wu, Bing-Dong Liu, Alex Chen
2nd
---No life cutoff---
Rohin Garg, Adam Gąsienica-Samek, Ryan Bai, Austin Geng
3rd
Infrared
Mohamed Bakry, Erekle Roinishvili, Luka Mosiashvili, Alperen Tupurtu
4th
batswana potato pride
Ko Kin Fung Nicholas, Wong Chun, Wang Chi Ho, Lu Yi Fung
5th
mike4235 fanclub
Tran Xuan Bach, Pham Quoc Hung, Hoang Ngoc Bao Khue
Novice Division
1st
Ninja go
Omar Ahmed Abdelaziz, Yahia Emara, Adam Aly, Mina Ragy
2nd
LOL Team
Ahmed Gamal, Yahia Ahmed, Moez Mahmoud, Ahmad Amin
3rd
ctcOTZ
Ishan Joshi, Srivaths P, Naveen Pramod Kulkarni, Yash Haresh Thakker
4th
404 Error: Name not Found
Bharat Singla, Adhish Kancharla, Bhavay Goyal, Ananthram Vijayaraj
5th
u r a queue<T>
William, Cole, Tatha, Akksharvan

Schedule Overview

Opening Ceremony and Rule Review
Join us at Youtube Livestream to watch the opening ceremony. We will also be going over the rules of the contest.
Aug 12th 9:15 AM - 9:45 AM PDT
Coding time! Last submission by 12:45 PM
Login to TeamsCode Contest Portal and start coding! All team members can submit solutions and get instant feedbacks until 12:45 PM.
Aug 12th 9:45 AM - 12:45 PM PDT
Lunch Break
Please take a break while we get ready for the speaker event.
Aug 12th 12:45 PM - 2:00 PM PDT
Guest Speaker Event - Mr. Michael Plunkett
Faulty Enzymes and Off-by-One Errors: Finding Joy in Problem Solving by Mr. Michael Plunkett
Aug 12th 2:00 PM - 3:00 PM PDT
Raffle, Contest Winners Announcement, and Closing Ceremony
Tune in to our Youtube Livestream to watch the winners announcement, raffle, and our final closing ceremony.
Aug 12th 3:00 PM - 3:30 PM PDT
Aug 12th  9:15 AM -  9:45 AM
Opening Ceremony and Rule Review
Join us at Youtube Livestream to watch the opening ceremony. We will also be going over the rules of the contest.
Aug 12th  9:45 AM -  12:45 PM
Coding time! Last submission by 12:45 PM
Login to TeamsCode Contest Portal and start coding! All team members can submit solutions and get instant feedbacks until 12:45 PM.
Aug 12th  12:45 PM -  2:00 PM
Lunch Break
Please take a break while we get ready for the speaker event.
Aug 12th  2:00 PM -  3:00 PM
Guest Speaker Event - Mr. Michael Plunkett
Faulty Enzymes and Off-by-One Errors: Finding Joy in Problem Solving by Mr. Michael Plunkett
Aug 12th  3:00 PM -  3:30 PM
Raffle, Contest Winners Announcement, and Closing Ceremony
Tune in to our Youtube Livestream to watch the winners announcement, raffle, and our final closing ceremony.

Contest Details

General Rules

  • Only teams with only middle or high school students (rising 6th - senior) are eligible for prizes, however everyone (college students, workers) is welcome to compete.
  • Each team may have up to 4 people. Team members may not receive any help from anyone outside of their team.
  • Teams must submit at least once to be eligible for raffle prizes.
  • Teams may use multiple computers and submit answers in multiple languages.
  • Pre-written code and online reference guides are allowed (in other words, internet is allowed so long as you’re not asking people how to solve our problem).
  • We reserve the right to disqualify participants who intentionally participate in divisions with problem difficulties that are too low for the skill level of the participant. For example, USACO finalists and International Masters on Codeforces cannot participate in the Novice division. We do not tolerate those who attempt to undermine the fairness of the competition.
  • There are two divisions: Novice and Advanced. We expect each division will be interesting for participants of the following skill levels:
    • The novice division is intended for students who know programming but have not started or have just started competitive programming:
      • Taking or have taken APCS
      • USACO Bronze-Silver
      • 0 - 1500 Codeforces rating
    • The advanced division is intended for anyone who is confident in their competitive programming ability:
      • USACO Gold and above
      • 1600+ Codeforces rating
  • Contest page: https://summer23.teamscode.org
  • Join our discord server here: https://go.teamscode.org/discord for important contest announcements or if you have any questions.
  • Try more problems from the last contest:

Problem Format

  • Description: an overview of the problem.
  • Input Format: specifies how the input will be formatted, including constraints on the size of parameters. (constraints may be stated in the Description).
  • Output Format: specifies how the output should be formatted - if you don’t follow this format exactly, your answer will most likely be marked as incorrect.
  • Sample Input: provides a sample input to help you test your code.
  • Sample Output: provides the expected output to the sample input.
  • Sample Explanation: provides an explanation of how the sample output was obtained from the sample input.

Submitting Solutions

  • Allowed Languages: C++, C, Java, Python 2, Python 3
  • Solutions will be submitted through the contest page listed above. The code for each problem should be copy-pasted into the box that appears after clicking “Submit Code”.
  • For Java submissions, the class name of your main function must be Main.
  • The file size containing your code must not exceed 50 KB.
  • Default Constraints
    • Note that constraints may vary depending on the problem.
    • Time Limit: Your program must run in under 2,000 ms (2 seconds) for C and C++, under 4,000 ms (4 seconds) for Java, and under 8,000 ms (8 seconds) for Python. Time limits for each language may be different if specified in a problem.
    • Memory Limit: The program's memory must not exceed 256 MB
  • Use Standard Input in your code. This means that test cases are directly typed into the console. Here’s an example for each of the allowed languages:
    Java: Scanner(System.in) C++: cin>> Python: input() C: scanf()
  • Use Standard Output in your code. This means that the output directly prints to the console. Here’s what standard output looks like for each of the languages:
    Java: System.out.println() C++: cout<< Python: print() C: printf()

Scoring

Problem Difficulty

  • There are ~10 total problems in ascending order of difficulty.

Problem Points

  • All problems are each worth 100 points. Each problem has some number of tests (usually 10 or 20). Sample test is worth 0 point. If you solve X non-sample tests correctly for a problem with Y non-sample tests, you get (X/Y * 100) points.
  • Note that each test may have multiple test cases where each test case must be solved correctly to get points for the test.
  • Output must match exactly with expected output to receive points for the test case - there is no partial credit.

Problem Tests

  • The first test is always the sample given in the problem.
  • Some problems will have explicitly stated subtasks. For example, a problem with 10 tests may have tests 1-5 with N<=10 and tests 6-10 with N<=100.

Ties

  • Ties will be broken by the timestamp on the last submission that increases your total score.